/ ios

iOS 8 and Xcode 6

Greetings,

Due to multiple support requests about iOS 8 we thought it’d be good to also shed some light here in our Blog. Currently, there are two version of Pushwoosh iOS SDK:

  • iOS 7 SDK – must be compiled with Xcode v.5 – does not support latest features introduced in iOS 8;
  • iOS 8 SDK – must be compiled with Xcode v.6

So, applications compiled with iOS 7 SDK in Xcode v.5 will continue working properly on devices running iOS 8 due to its compatibility. If you use Pushwoosh iOS 8 SDK, you must compile your app with Xcode v.6.

**NOTE:** The post was updated on September, 25.